BeBits Information Developer Central Submit Application Your Account Web Links Contact Us
BeBits
DOSBox
Talkback
 Go back to the DOSBox page
 Post a new Talkback comment!
0.62 build for BeOS...
 By MYOB - Posted on October 26, 2004 - 02:52:57   (#14517)
 Current version when comment was posted: 0.61
...is here http://myhome.iolfree.ie/~seagullsireland/DOSBox 0.62.zip

Apologies for the net+ unfriendly URL, didn't realise it until I'd uploaded it...


german translation of DosBox ReadMe file
 By lelldorin - Posted on July 25, 2004 - 16:11:06   (#13563)
 Current version when comment was posted: 0.61
please inlcude this german translation of the readme document into your project package.

placed at: other reviews

Arrow keys
 By Das Jott - Posted on June 17, 2004 - 18:47:46   (#12941)
 Current version when comment was posted: 0.61
Thank you very very much tb100 :)

Great solution! Works really good and I am happy :-)

re: arrow keys
 By tb100 - Posted on June 16, 2004 - 16:49:14   (#12909)
 Current version when comment was posted: 0.61
There is a solution to the arrow keys problem:
http://www.beemulated.net/phorum/read.php?f=1&i=367&t=367

Arrow keys
 By Das Jott - Posted on June 15, 2004 - 17:17:34   (#12888)
 Current version when comment was posted: 0.61
At first: thanks for this very cool DosBox!
I could install and start a few nice Dos-games now.

But in some game-setups, you need to select the options with the arrow-keys.
These games are simply not installable, because the arrow keys are not working (correctly) in DOSBox.

All other games I tried worked fine :-)


opengem gui works
 By marduk - Posted on April 22, 2004 - 21:41:18   (#12155)
 Current version when comment was posted: 0.61
only gemmini works, the full version contains a memory manager that is incompatible with dosbox.
get it here http://www.shaneland.pwp.blueyonder.co.uk/GEMINI.ZIP

First you need to...
 By Jess - Posted on April 16, 2004 - 15:52:08   (#12077)
 Current version when comment was posted: 0.61
First you need to watch your language. Second off yes emulation is slow. Unless you have a crazy fast computer give up cuz no amount of tweaking is going to help. THE END For your Wolfenstein deal you have to write a script. Go read...

Deluxe Ski Jump 2.1
 By OKKUFO - Posted on April 16, 2004 - 12:30:46   (#12075)
 Current version when comment was posted: 0.61
I installed Deluxe Ski Jump 2.1 as the first game in DOSbox, the installation went well but when I was supposed to play it, it was so goddamned slow, so that I could actually see each frame :( What am I supposed to do about this?

system shock 1 works
 By marduk - Posted on February 27, 2004 - 12:08:18   (#11257)
 Current version when comment was posted: 0.61
a little slow but it works

Thanks for the feedback
 By goodoldgames - Posted on February 22, 2004 - 18:22:04   (#11182)
 Current version when comment was posted: 0.61
Thanks for the feedback! I will mail you ...

Several issues
 By Eddyspeeder - Posted on February 22, 2004 - 14:43:45   (#11176)
 Current version when comment was posted: 0.61
Dear GoodOldGames,

First off a big thank you for porting DOSBox to BeOS/Zeta and maintaining the emulator. Over the last month I have revived my youth (eek that sounds old), playing all episodes of Commander Keen, Duke Nukem 1 - 3, Crystal Caves 1 - 3, and so on.

There are, however, a number of issues I would like to bring to your attention. I do not demand of you to implement them, although I feel it will vastly improve the workability and user-friendliness of DOSBox.

Let's start with two issues in general.

1) I have a Sound Blaster Live! in my system (emuxki driver). Although it does play the sound and music (the music is however played at about 50% of its original speed), I also hear a continuous and monotone crackling noise while playing a game. Mostly it gets a bit muted as I play music, but if a song in SoundPlay has a few seconds of silence or something, it really hurts my ears. Perhaps you know what causes this or what I can do to remove this noise?

2) The other one is related to video. I have noticed DOSBox resizes the screen to 800x600 at a refresh rate of 52.2 Hz. Now, that isn't much of an issue, but when I play it fullscreen, the "active screen" is only 640x400 (nope, not 480, 400).

For the following examples I will use my installation CD of GTA1.

3) The cursor keys should have different functions assigned. When I press "up", I see a triangle pointing upwards. Instead, I think it would be best to show the last command given. Also, the left and right cursor key should enable someone to move through the command to make changes in there. The down-button should go to a command given at a latter time, or, when there is none, it should do nothing. Assigning new features will enable a user to not having to rewrite a command every time. Additionally, keys like PrintScrn display 1 when pressed (see the screenshot I refer to in issue #5).

4) I have noticed that when switching folders, DOSBox is not really strict on whether you use capital or small letters. However, when performing the MOUNT command, it does require so, for instance mount "/GRANDTHEFTAUTO/". I think this is a bit of an inconsistency, but I'm not sure how it should be dealt with. One part of me says it would be easier to just ignore case, another part of me foresees problems when there are two folders with the same name only one being fully lowercase and another having one or more capitals in it.

5) As Zeta has been the only operating system on my machine for quite some time by now, I cannot install GTA away from DOSBox and then play it in DOSBox. If you see my screenshot on http://www.skycycleonline.com/sars/dosbox.png, you'll see that I first try to run install.bat, which is to start k.exe, plus calls for dino.bat. Running k.exe from C: also returns an error, as the screenshot shows. However, when I'm on D: and run either install.bat or k.exe there, it just starts up. However, when I tell it to install to C:\GTA, it returns "Could not change directory". This example proves that when a batch file on another drive is run, DOSBox somehow assumes that the files the batch file refers to is located on your current drive in stead of on the drive the batch file is located on. That is wrong. And why k.exe starts complaining about dos4gw all of a sudden, I don't really know.

I hope the situations I described above made sense to you. I am willing to help you out wherever I can, in trying out things and telling you what the outcomes are. mailto:eddy@skycycle!!!NOSPAM!!!online.com (remove the !!!NOSPAM!!!).

Using MPU-401 with the BeOS
 By euporia420 - Posted on November 2, 2003 - 10:28:06   (#9442)
 Current version when comment was posted: 0.60
Does anyone know how to use the MPU-401 emulation capabilities in DOSBox?

Does it requer a SB compatable sound card, with 401 joystick-to-midi capabilities, or does it actually emulate the 401 and allow me to use any MIDI port detected by BeOS (i.e. I'd like to use my Echo Layla or Yamaha UX256)?

I'd love to get some use out of this app for MIDI. Anyone know how to set-up the midi?

-David
BeShare - :Wumpscut:
http://www.bebits.com/devprofile/3344

Solution for mouse problem
 By goodoldgames - Posted on October 26, 2003 - 19:05:51   (#9365)
 Current version when comment was posted: 0.60
If you have problems with the mouse moving too fast out of the window, open the file dosbox.conf in your dosbox direcrory and edit the value behind the word "sensitivity". I changed it to 300 and the mouse is now working very well here.



Lots of changes, thanks! & Protected mode afterall?
 By Jace - Posted on October 21, 2003 - 00:13:16   (#9300)
 Current version when comment was posted: 0.60
I notice "basic support for 32-bit protected mode" is in there... Odd...

This is cool software. I am finally able to play some old favorites in BeOS because of DOSBox (like the original StarControl).

Wierd problem
 By Jess - Posted on October 20, 2003 - 04:39:00   (#9285)
 Current version when comment was posted: 0.60
Hey,
to things - mouse still isnt too useable & the wierd thing is
playing scorched earth page up & down is a faster way to do power up & power down for your shots. When I press page up in the new version of dos box it switches me to workspace 3 for some whack reason.

Re:dr_evil
 By hardedged - Posted on October 19, 2003 - 23:33:38   (#9283)
 Current version when comment was posted: 0.60

You have to hit CTL+F10 to grab the mouse first. This behaviour is slightly different on the BeOS platform (it auto-grabs at some times on other platforms, whereas on BeOS it does not in the same situations).



0.60 keyboard-shortcuts?
 By dr_evil - Posted on October 19, 2003 - 23:05:42   (#9282)
 Current version when comment was posted: 0.60
is it possible that the keyboard-shortcuts (frameskip, cpu cycles) don't work anymore?

i guess dosbox hasn't net capability ...
 By Triphylliander - Posted on April 24, 2003 - 20:10:31   (#7031)
 Current version when comment was posted: 0.58
didn't try.
maybe in a later version.

Does DOSBox have net capability? How would you use Pegasus?
 By Jace - Posted on April 23, 2003 - 19:48:19   (#7014)
 Current version when comment was posted: 0.58
The school I work at has standardized on Pegasus for Windows. I hate it. So I use Eudora instead. Pegasus has a terrible UI and is about as different from everything else as you will get (and in this case, that's a negative).

for the friends of PegasusMail ...
 By Triphylliander - Posted on April 23, 2003 - 19:11:37   (#7013)
 Current version when comment was posted: 0.58
also the DOS-version ( ftp://ftp.usm.maine.edu/pegasus/dos/pmail350.zip ) of this program works in DosBox. if it has any sense to use this program is another question ...

OK, One More Time...
 By FreonTrip - Posted on April 18, 2003 - 00:59:14   (#6924)
 Current version when comment was posted: 0.58
As shamelessly ripped from the homepage:

"DOSBox doesn't run any protected mode games, stop bothering us about those. In general this will mean games coming out after 1993, you can recognize most since they have DOS4GW.EXE in the game directory."

I would imagine that support for protected mode will be added in a future release; at the moment it would seem the developers are focusing on getting DOS' core functionality down pat before proceeding on to the trickier business of making protected mode work. And I can't WAIT for that day. ^_^

with all respect ...
 By Triphylliander - Posted on April 17, 2003 - 16:33:08   (#6920)
 Current version when comment was posted: 0.58
... cool program, but any bugs. maybe someone can tell me if (and how) to resolve ...


Monkey Island 1 + 2 runs without problems.

in cd-menus, you can only jump to the first or last point of the list with the Pg-up-/Pg-down-keys, what isn't very successfully, if the program, that you want to install, isn't displayed as first nor as last point.

you can install some things, but if you start it DosBox will crash ... like Warcraft.
Reunion could be install (with much patience) and started. Intro ran, but could not be broken off. the DosBox broke off for it.

Synnergist could not be installed in BeOS, 'cos the mentioned key-problem prevented the configuration of the sound-card. while starting, it criticized a lack of MSCDEX.

Crusade, Der Planer, Dragonsphere, MAD TV 2, Archibald Applebrook, Talisman, Gene Machine, Knights+Merchants, Imperium Romanum, MDK, Dime City, Cyberia, Star Blade, Pirates, Fable aren't running, so far as I have noticed.

Games like Dominium, Burntime or DSA can be installed with luck, but the configuration cannot be executed.

Keyboard and up/right arrow issue.
 By Diver - Posted on April 4, 2003 - 13:27:29   (#6726)
 Current version when comment was posted: 0.58
Thanks for this app, but it have some nasty bugs...
1. if you press left arrow it should show last message, but it show "->" letters instead.
2. Keyboard don't work in Dos Navigator...
3. Fullscreen should resize fonts (e.g. in DN).
4. Fonts in the standard should be shiifted from the borders by some pixels.

Thanks again.

Awesome!!!
 By arougthopher - Posted on April 4, 2003 - 07:15:54   (#6725)
 Current version when comment was posted: 0.58
Finally, I can play one of my favorite Chess games ever ... BattleChess! Works perfectly! Thank you!

I'm a dummy, never mind.
 By Jace - Posted on April 1, 2003 - 03:33:50   (#6682)
 Current version when comment was posted: 0.58
POP = Prince Of Persia

Ram: POP? What's that?
 By Jace - Posted on April 1, 2003 - 03:32:59   (#6681)
 Current version when comment was posted: 0.58
You said you saw POP on this DOSbox and then deleted it. What's POP?

re: Ram
 By Jess - Posted on January 5, 2003 - 09:29:48   (#5156)
 Current version when comment was posted: 0.57
Hey,
Ya your going to find most any game unplayable with your system sadly. I am sitting on a k6-2 550 with 768mb of ram & all I use dosbox for is scorched earth. There was a release a while back that mae things run pretty well but even though you can change the timing I find the newer versions have been ungodly slow & unplayable again. I have disscussed these thigns at length with many people - some say games where fast in dosbox or sdl games on a lesser cpu then ours yet nothnig in playable on my system. They try to say it's my mother board or this or that but I have tested this on many k6-2 mobo with many differant cpu all with over 256mb of ram & nothing is playable. sadly to game in Be even for games that should be doable by a p1 90mhz your gonna need to by a min of an athlon 1600... VERY sad...

POP on DOSbox
 By Ram - Posted on January 5, 2003 - 03:16:39   (#5154)
 Current version when comment was posted: 0.57
Well, anyone tried playing Prince of persia 1 on this dosbox?

Its slower than i can possibly describe. I dont know how games like Blakestone etc could have worked...

Could it have something to do with my hardware?: I have an AMDK6-2 450 MHz, 128 MB RAM.

Anyway, after seeing POP on this dosBox i deleted the app from my system.

I'm disappointed, but I will be checking the future versions. Hope the speed and the sound improves.

really great! only..
 By m7m_GuyHaviv - Posted on January 4, 2003 - 23:46:38   (#5150)
 Current version when comment was posted: 0.57
i really love this app, especially the use of sdl to emulate a PC textmode .. which allows me to run aciddraw/itpdraw and draw asciis on BeOS !

now all i need is better speed , and more responsiveness.. (couldn't spell that ..)

Great work! keep going :)

(already talked to you about that great font thingie :)

Geat!
 By bbjimmy - Posted on December 31, 2002 - 01:59:43   (#5054)
 Current version when comment was posted: 0.57
I can now run many DOS programs -- including games -- that I had to re-boot to run before. It now needs to support the dos path command and most of my DOS needs will be met.

nice update...
 By fanskapet - Posted on December 29, 2002 - 22:09:31   (#5036)
 Current version when comment was posted: 0.57
ahh. the old finish game Threat works in DosBox now :D.. very nice :D

Note: No protected mode games for DOSBox
 By Jace - Posted on December 5, 2002 - 02:41:51   (#4599)
 Current version when comment was posted: 0.56
I just noticed this on the DOSBox site:

"DOSBox doesn't run any protected mode games, stop bothering us about those. In general this will mean games coming out after 1993, you can recognize most since they have DOS4GW.EXE in the game directory."

Just in case anyone hadn't known this ;-) Oh well, there's a ton of great games that aren't protected mode anyway...

& that is why you fail... - Yoda
 By Jess - Posted on November 2, 2002 - 02:14:56   (#3888)
 Current version when comment was posted: 0.56
Well this is disapointing. Dosbox is great & has "Wow'd" me since I first tried it but this version has some problems. It's a big set back & speed & freezes alot. Not a permanent app freeze but while doing certain animations in games. Blow an enemy up... expect a wait. Hope this is worked out in the next version. In any case thanks for the time put in. I know in the end this will be a killer app.

DOSBox is great!!
 By ahwayakchih - Posted on November 1, 2002 - 12:46:18   (#3885)
 Current version when comment was posted: 0.56
i can play best RPG and Adventure games on BeOS now! :D

more working games...
 By cypress - Posted on September 26, 2002 - 10:23:21   (#3318)
 Current version when comment was posted: 0.55
Tried dosbox with Dune [I] - works great!
Also works with Wolfenstein 3D, Spear of Destiny, Blake Stone: Planet Strike, Skyroads - These are a little slow but work with sound.

well I tried
 By Jess - Posted on September 2, 2002 - 23:12:49   (#2979)
 Current version when comment was posted: 0.55
Heh... Gave the new version a try soem nice speed ups - also some wierdness. resizing a game window changed my resolution & not the window size - the end result was my game got smaller heh. So I grabbed one of my dos nes emulators a copy of dos4gw & prayed. Crashed it... oh well I gave it a shot. Dosbox is comming along well & I totaly thank the dev's!

Working game
 By goodoldgames - Posted on August 16, 2002 - 08:15:50   (#2676)
 Current version when comment was posted: 0.50
The full version of Wolfenstein 3D (not the shareware!!) is working perfectly with sound.

Runs fone for me...
 By Jess - Posted on August 16, 2002 - 08:04:16   (#2674)
 Current version when comment was posted: 0.50
I play Scorched Earth in this & this version has some noticable speed ups. Sadly a few other details seem to have slowed down but either way it's playble at 320x240. If you havent got your Decent 1 to work make sure you have the config set for REALLY LOW resolution unless your packing dual 2ghz athlons ( total 4 ghz ) I cant run scorched earth at all at 640x480. So edit your config manually in a text editor & make sure your res is low. If they dont work then
#1 there is somthing in Decent dosbox dont like
#2 your system sucks big time ( p 200 64mb of ram )
#3 your doing something wrong

What games have you been able to run there?
 By Lanjoe9 - Posted on August 16, 2002 - 07:37:44   (#2673)
 Current version when comment was posted: 0.50
I haven't been able to run even the Descent 1 Setup app... duh..

Comment Pages:    << prev  |  1  |  2  |  next >>
 
BeGroovy
  Recent Downloads  -  # 25
Total Downloads  -  # 49
Total Views  -  # 37
User Ratings  -  # 10
  Computer Emulators
1.  BePodder - 9.73
2.  QEMU - 9.68
3.  ScummVM - 9.57
4.  VNCServer - 9.36
5.  Haiku AGP busm... - 9.35
6.  cpu_fix - 9.31
7.  vim6 - 9.31
8.  Beezer - 9.26
9.  HandBrake - 9.25
10.  BeeF - 9.25
1.  Ati Radeon G... - 43,775
2.  BeOS 5 Perso... - 39,088
3.  BePDF - 26,407
4.  Realtek RTL8... - 21,080
5.  Ensoniq Audi... - 20,754
6.  USB Joystick... - 18,019
7.  VLC Media Pl... - 15,024
8.  ATI Rage 128... - 13,964
9.  DOSBox - 12,439
10.  S3 Trio 64 v... - 11,375
You are not logged in.
 Login

 
Unless otherwise noted, everything is copyright © 1999-2013 Haikuware. All Rights Reserved.
For more legal trivia, take a gander at our
Legal Stuff page and our Privacy Statement.
Website Deisgn: NumbDesign